Maintenance of Cobbler 2.4.x is targeted at Enterprise Linux 5 (eg. RHEL5/CentOS5) and thus requires python 2.4

Source

Packages