Cobbler 2.4.0-1 Released

Posted by James on Thursday, June 20, 2013

I am happy to announce that after a year since the last release, Cobbler 2.4.0-1 is now officially available! The build process has been started for Fedora/EPEL, so the packages should be available in the -testing repos within a day or two, and in the stable branches following that (EPEL takes longer).

Some highlights of the release:

Major Features:

  • Dynamic Settings (Sorry we don’t have 2.4.0 docs anymore)
  • Distro Signatures (Sorry we don’t have 2.4.0 docs anymore)
  • Vastly improved support for Ubuntu, OpenSUSE and VMware ESXi (5.0 and 5.1)
  • Added in new templated scripting support (needs documentation)
  • New web interface improvements (tabs, etc.)
  • Added apt-specific fields for repositories to make mirroring them easier
  • Support for parameterized classes and defines in puppet using management classes

Minor Features:

  • Added the bonded_bridge_slave interface type:
  • Improved template error reporting
  • Variables in fields are now evaluated through the templating engine
  • Added openvz as a virtualization type for koan
  • Added –virt-pxe-boot option for koan to force PXE booting of new systems
  • Added a per-interface gateway option, for systems that support it
  • Added support for new puppet command syntax
  • Exposed replication rsync options

Major Bugfixes:

  • –available-as no longer copies all files.
  • Improved gPXE/iPXE support, including FreeBSD
  • Deleting objects now respects the –recursive option again

Minor Bugfixes:

  • Too many to list

Thanks to everyone who made this release possible!


comments powered by Disqus